Error with new GLPosting.inc when addding a GL account

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error with new GLPosting.inc when addding a GL account

Pak Ricard
Hi Exson:

For business reasons, I just had to create a new GL account and record a transaction against it. When I tried to see the balance sheet afterwards I get this error:

Database Error 1064 : Failed to retrieve new account code and periods
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'code IS NULL ORDER BY accountcode,periodno' at line 6
Database SQL Failure : The SQL that failed was
SELECT chartmaster.accountcode,periods.periodno FROM (chartmaster CROSS JOIN periods) LEFT JOIN chartdetails ON chartmaster.accountcode=chartdetails.accountcode AND periods.periodno=chartdetails.period WHERE (periods.periodno BETWEEN '-14' AND '106') AND chartdetails.account code IS NULL ORDER BY accountcode,periodno

I think it's related to the new GLPosting.inc file, as it's the only updated file we played with lately. I reverted the GLPosting.inc file to the previous version and worked OK again, so seems like related to the new GLPosting.inc

Could you please check it out?

Regards,
Ricard

------------------------------------------------------------------------------
Transform Data into Opportunity.
Accelerate data analysis in your applications with
Intel Data Analytics Acceleration Library.
Click to learn more.
http://makebettercode.com/inteldaal-eval
_______________________________________________
Web-erp-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-developers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error with new GLPosting.inc when addding a GL account

ExsonQu
Administrator
Hi, Richard,

               Thank you for your feedback.  I'll check what goes wrong.
               
               Thanks and best regards!

               Exson
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error with new GLPosting.inc when addding a GL account

ExsonQu
Administrator
In reply to this post by Pak Ricard
Hi, Richard,

                Just check it and found it's a typo which typed account code instead of accountcode. Sorry for the mistake.

                Please check if this problem fixed and if there are any other problem.

                Thanks and best regards!

                Exson
                GLPostings.inc
Loading...