Problem after upgraded

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem after upgraded

StevenTang
Hi,

I just updated from 3.08 to 3.11.3 (skipped some version).  However, I found some problems.  May be some of the problem is posted before, but I don't know where to found the solution.  Please kindly help.

1.  in "work order entry", when I select an item to add/search, it was error as below. it was worked in 3.08.   I installed a dummy in another server with new database.  It works.  So if it is problem of mysql?

Database Error
:
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT stockid
FROM worequirements WHERE wo = 45 AN
Database SQL Failure : The SQL that failed was
INSERT INTO worequirements (wo, parentstockid, stockid, qtypu, stdcost, autoissue) SELECT 45, '036371', bom.component, bom.quantity*1, materialcost+labourcost+overheadcost, bom.autoissue FROM bom INNER JOIN stockmaster ON bom.component=stockmaster.stockid WHERE bom.parent='036371' AND bom.loccode ='CSJ' AND stockmaster.mbflag<>'G' AND bom.component NOT IN ( SELECT stockid FROM worequirements WHERE wo = 45 AND parentstockid = '036371' )

2. similar to above, when using List Components Required, after input qty.  it have error as below.  Same work in new server and database but not in upgraded.  The old one is Mysql4.026.  and the new one is 4.1.20.  Is this the reason?

Database Error :
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT SUM(locstock.quantity) as invqty
Database SQL Failure : The SQL that failed was
SELECT tempbom.component, SUM(tempbom.quantity) as quantity, stockmaster.description, stockmaster.decimalplaces, stockmaster.mbflag, (SELECT SUM(locstock.quantity) as invqty FROM locstock WHERE locstock.stockid = tempbom.component GROUP BY locstock.stockid) AS qoh, (SELECT SUM(purchorderdetails.quantityord - purchorderdetails.quantityrecd) as netqty FROM purchorderdetails WHERE purchorderdetails.itemcode = tempbom.component AND completed = 0 GROUP BY purchorderdetails.itemcode) AS poqty, (SELECT SUM(woitems.qtyreqd - woitems.qtyrecd) as netwoqty FROM woitems WHERE woitems.stockid = tempbom.component GROUP BY woitems.stockid) AS woqty FROM tempbom,stockmaster WHERE tempbom.component = stockmaster.stockid GROUP BY tempbom.component, stockmaster.description, stockmaster.decimalplaces, stockmaster.mbflag

3. when running the upgrade script of sql have many error come out.

4. the status of purchase order cannot be changed to Printed after printed, so it cannot receive goods.  Also sometime it cannot print even authorized.  Will this effect of translation of language?

5.  Now it can set to "release new work order" when inputing new order automatically, it didn't work (may be same problem as above). But in the same time, it will issued a new invoice but blanked.

6.  I found that webERP already supporting utf-8.  it is good news. But I tried to build a dummy system but it have an error when I try to print PDF.  Please kindly help.


Fatal error: Class 'Cpdf' not found in /home/httpdocs/webERP/includes/PDFStarter.php on line 100

7.  How can I retrieve the data only from mysql,  and rebuild all the table by the sql from 3.11.3 and put all the data back?   Because the database have many error message come out when upgrading.  I am afraid that some table was damage or not modified according the new version.  Specially the constraint key.

8.  The messages.po even in en_US, do not contain all the sentences of 3.11.  Please kindly help in this, and let me know how to use gettext to merge the new po file with old translated one.  Thanks.


Thanks for all in advance.

Steven


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

ExsonQu
Administrator
Steven:
 
           I've check the scripts of those upgrading sql,  it shows that the sql function is to add new tables to database or alter some tables. So if you skip those script from 3.08 to 3.11. These tables in the databases are quite different. The error to run the php script of 3.11 directly is inavoidable.
            I think your question from 1~5 are from this. You should run the Z_upgrade scripts one by one. Then your data should be intact.

         you can check the http://www.weberp.org/HowToupgrade website for details:

Upgrading the Database to Run with the New Scripts


Log in to your new system with a system administrator login and password.

>From version 3.04 there has been automated scripts that perform the upgrade to the database automatically. You must run each of these scripts in turn - by entering the URL directly in your browser's "location"/navigation bar.

Z_Upgrade_3.04-3.05.php

follow the prompts to perform the database changes - any changes required to the data structure will also be performed using these scripts.
then ...
Z_Upgrade_3.05-3.06.php
Z_Upgrade_3.06-3.07.php
Z_Upgrade_3.07-3.08.php
etc...

You will need to do this process for each company you run webERP on.
That's it!

 concerning to utf8 code, I don't know what kind of Language is used by you. I've revise some script to display Simplify Chinese for weberp3.11.2. I have no experience about the 3.11.3. It seems that you did not put class.pdf.php in your includes directory. Please check if the file is there.
   
  To your question 7~8, could you like to study the scripts LanguageSetup.php in the includes path? It will show you the function _( ). And I have some reply about the Transilation question from Baran. It may solve parts of your question.

    Best regards!

    Exson Qu




------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

回覆: Re: Problem after upgraded

StevenTang

Hi Exson,

I already run upgrade one by one.  That why i found that many error through upgrade.

I will try to run again tomorrow.  However, the mysql was changed already.    I am not sure if the upgarde script can work again.

Thanks

I am also using the language zh_cn.utf8

Steven

2010-6-15 下午10:14在 "exson qu" <[hidden email]> 提到:

Steven:
 
           I've check the scripts of those upgrading sql,  it shows that the sql function is to add new tables to database or alter some tables. So if you skip those script from 3.08 to 3.11. These tables in the databases are quite different. The error to run the php script of 3.11 directly is inavoidable.
            I think your question from 1~5 are from this. You should run the Z_upgrade scripts one by one. Then your data should be intact.

         you can check the http://www.weberp.org/HowToupgrade website for details:

Upgrading the Database to Run with the New Scripts


Log in to your new system with a system administrator login and password.

>From version 3.04 there has been automated scripts that perform the upgrade to the database automatically. You must run each of these scripts in turn - by entering the URL directly in your browser's "location"/navigation bar.

Z_Upgrade_3.04-3.05.php

follow the prompts to perform the database changes - any changes required to the data structure will also be performed using these scripts.
then ...
Z_Upgrade_3.05-3.06.php
Z_Upgrade_3.06-3.07.php
Z_Upgrade_3.07-3.08.php
etc...

You will need to do this process for each company you run webERP on.
That's it!

 concerning to utf8 code, I don't know what kind of Language is used by you. I've revise some script to display Simplify Chinese for weberp3.11.2. I have no experience about the 3.11.3. It seems that you did not put class.pdf.php in your includes directory. Please check if the file is there.
   
  To your question 7~8, could you like to study the scripts LanguageSetup.php in the includes path? It will show you the function _( ). And I have some reply about the Transilation question from Baran. It may solve parts of your question.

    Best regards!

    Exson Qu




------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

回覆: Re: Problem after upgraded

StevenTang
In reply to this post by ExsonQu

hi exson

Where i can find yoir answwr to baran?

Thanks

2010-6-15 下午10:14在 "exson qu" <[hidden email]> 提到:

Steven:
 
           I've check the scripts of those upgrading sql,  it shows that the sql function is to add new tables to database or alter some tables. So if you skip those script from 3.08 to 3.11. These tables in the databases are quite different. The error to run the php script of 3.11 directly is inavoidable.
            I think your question from 1~5 are from this. You should run the Z_upgrade scripts one by one. Then your data should be intact.

         you can check the http://www.weberp.org/HowToupgrade website for details:

Upgrading the Database to Run with the New Scripts


Log in to your new system with a system administrator login and password.

>From version 3.04 there has been automated scripts that perform the upgrade to the database automatically. You must run each of these scripts in turn - by entering the URL directly in your browser's "location"/navigation bar.

Z_Upgrade_3.04-3.05.php

follow the prompts to perform the database changes - any changes required to the data structure will also be performed using these scripts.
then ...
Z_Upgrade_3.05-3.06.php
Z_Upgrade_3.06-3.07.php
Z_Upgrade_3.07-3.08.php
etc...

You will need to do this process for each company you run webERP on.
That's it!

 concerning to utf8 code, I don't know what kind of Language is used by you. I've revise some script to display Simplify Chinese for weberp3.11.2. I have no experience about the 3.11.3. It seems that you did not put class.pdf.php in your includes directory. Please check if the file is there.
   
  To your question 7~8, could you like to study the scripts LanguageSetup.php in the includes path? It will show you the function _( ). And I have some reply about the Transilation question from Baran. It may solve parts of your question.

    Best regards!

    Exson Qu




------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: 回覆: Re: Problem after upgraded

phildaintree
In reply to this post by StevenTang
Once the upgrade script has been run once it will run into errors if you try to run it again. Unfortuantely there is then no substitute for working through the upgrade scripts to see what has and has not been changed by inspecting the db structure through say phpmyadmin.

If a change in the sql scripts has not been applied then run that statenent through the sql tab of phpMyAdmin

Phil
Phil Daintree
Logic Works Ltd - 0275 567890

-----Original Message-----
From: Steven Tang <[hidden email]>
Date: Tue, 15 Jun 2010 22:57:28
To: For the general discussion of webERP project<[hidden email]>
Reply-To: For the general discussion of webERP project
        <[hidden email]>
Subject: [webERP-users] : Re:  Problem after upgr
        aded

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
If anyone is wondering about the persistently nasty comments made by Tim Schofield and wants the full story please see: http://timschofield.blogspot.com/ Hell hath no fury like a woman (or Tim) scorned
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

ExsonQu
Administrator
In reply to this post by StevenTang
Steven,
           
              I'm not sure if you've backup the mysql data before your upgrading. If you've kept the data, you can restore it and try it again.
              If you've not backed it up. You have a last solution to backup your current mysql database data now. And then compare it with the new version sql of weberp. It maybe time consuming.
        
           Following is the suggestion about translation part, hope it's helpful.
          
           BTW, if you've installed webERP in windows, it's not necessary to use utf8 version.


        

             Some suggestion about the translation as following:

             1. Please read the basic knowledge about gettext in the following sites:
               http://www.gnu.org/software/gettext/manual/gettext.html#Why  You can know how does the gettext work? What is .po and what is .mo etc.
             2. After you get the principal of i18n and l10n, then you can download a editor about PO. I use POedit and downloaded from following sites:
              http://www.poedit.net/   
            After install it, you can read the help documents to know how to use it. Just click the help menu. There is no seperate documents such as readme.
              3. You can go to the locale directory of weberp, then go to the directory of .po and mo.  You can choose the .po file and open it with POedit.
              4. If you want to extract the text need to be translated, you can choose the Catalog menu and you can see that the first choice is inactive (It means update the .po from source code, sorry I use Chinese Edition so I don't know the exactly text.). In order to activate it, you can click the setting choice in the same menu, then there is a window to add the path, you can add the basic path of your weberp, and then add your weberp directory. For example, you maybe have installed your weberp at c:\AppServ\www (It's basic path), and you weberp maybe under it and is named as weberp3.11.3, then you can put the weberp3.11.3 in the input boxes which is below buttons aIe, X.  Then confirm it.
               5. Then the choice of update from source is activated in Catalog menu, now you can click it. Then It will update your current .po file. It will extract the texts to translate from the orignal file. those texts are marked with _(' string') in those scripts.
              After you complete your translation, you can choose save as, then you can save it as po and you'll get po and mo at the same time in the directory which stores your files.
              
         Hope it is helpful.

         
         Exson Qu




------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

StevenTang
I don't know what to do now.

I restore mysql back to 3.08, and re-upgraded one by one again.  and it is the same result.  The woEntry not work.

So, I build a new database.  And found that it didn't work too.  ( it crash from the beginning after first input password as error :

Database Error :
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE currabrev='CHF'' at line 3
Database SQL Failure : The SQL that failed was
UPDATE currencies SET rate= WHERE currabrev='CHF'

why it was work in utf8 with mysql 4.1?In the new sql have the line DEFAULT=Latin1 is not good for mysql 4.0.  I must remove them before ran.

I'm not sure what to do.  But my utf8 server cannot print.  And now big5 version even cannot work.  it go back to the situation like 4 years ago when I started to use webERP.  However, is I have 4 years data here now.  I think it is a little like sql syntax not compatiable in version.  

For the Cpdf problem of utf8.  I have an idea that it is the problem of VDS problem I faced before.  It is because of rootpath of includes.  because vhost root cannot be access.  But I forgot how to set it.  Need more time to check how I solve that in five years ago.

How can I do?  Now is 11:00 at night.  Hope have someone help tomorrow morning.

Thanks......

Steven



2010/6/16 exson qu <[hidden email]>
Steven,
           
              I'm not sure if you've backup the mysql data before your upgrading. If you've kept the data, you can restore it and try it again.
              If you've not backed it up. You have a last solution to backup your current mysql database data now. And then compare it with the new version sql of weberp. It maybe time consuming.
        
           Following is the suggestion about translation part, hope it's helpful.
          
           BTW, if you've installed webERP in windows, it's not necessary to use utf8 version.


        

             Some suggestion about the translation as following:

             1. Please read the basic knowledge about gettext in the following sites:
               http://www.gnu.org/software/gettext/manual/gettext.html#Why  You can know how does the gettext work? What is .po and what is .mo etc.
             2. After you get the principal of i18n and l10n, then you can download a editor about PO. I use POedit and downloaded from following sites:
              http://www.poedit.net/   
            After install it, you can read the help documents to know how to use it. Just click the help menu. There is no seperate documents such as readme.
              3. You can go to the locale directory of weberp, then go to the directory of .po and mo.  You can choose the .po file and open it with POedit.
              4. If you want to extract the text need to be translated, you can choose the Catalog menu and you can see that the first choice is inactive (It means update the .po from source code, sorry I use Chinese Edition so I don't know the exactly text.). In order to activate it, you can click the setting choice in the same menu, then there is a window to add the path, you can add the basic path of your weberp, and then add your weberp directory. For example, you maybe have installed your weberp at c:\AppServ\www (It's basic path), and you weberp maybe under it and is named as weberp3.11.3, then you can put the weberp3.11.3 in the input boxes which is below buttons aIe, X.  Then confirm it.
               5. Then the choice of update from source is activated in Catalog menu, now you can click it. Then It will update your current .po file. It will extract the texts to translate from the orignal file. those texts are marked with _(' string') in those scripts.
              After you complete your translation, you can choose save as, then you can save it as po and you'll get po and mo at the same time in the directory which stores your files.
              
         Hope it is helpful.

         
         Exson Qu




------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users



------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

ExsonQu
Administrator
In reply to this post by StevenTang
HI, Steven,

      Just coold down and figure thing out.
      I've never try to upgrade the webERP from lower version to a lastest one. But I think we can solve the problem step by step. Since you've backed these sql data up, then I believe that we can upgrade the weberp system with some efforts.
      Since there is several php scripts you have to run during the upgrade, you can record the error messages step by step, then we can pinpoint what's wrong with that step.  
       Best regards!
       Exson
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

StevenTang
I don't know how to cool down after 24 hour work and fail.  And all the
office stop because of this.

I am not blaming anyone, because it is freeware.   But it really
problem.  Because I cannot host the server in China office, and I am not
always in Hong Kong.  So I must host the server in hosting company.  And
also I am not a programmer.

This restricted too much.  Anyway, I am trying to build in another
server from next hosting company.

Let see what happen next.

Steven

On 17/6/2010 7:23, ExsonQu wrote:

> HI, Steven,
>
>        Just coold down and figure thing out.
>        I've never try to upgrade the webERP from lower version to a lastest
> one. But I think we can solve the problem step by step. Since you've backed
> these sql data up, then I believe that we can upgrade the weberp system with
> some efforts.
>        Since there is several php scripts you have to run during the upgrade,
> you can record the error messages step by step, then we can pinpoint what's
> wrong with that step.
>         Best regards!
>         Exson
>    

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

sotandeka
Steven,

Since you are not a programmer, it might be very hard for you to figure out solutions to your errors.

The fastest solution might be to get a consultant (there are many on the mailing list) and for a few dollars (some might help for free) they help you sort out your problem in a very short time other than wasting time. 24 hours is a lot of time and cost to your company if the business stopped because of this.

Otherwise post the errors you get on the mailing list and you will get help from the experts.

P.

On Thu, Jun 17, 2010 at 5:51 AM, Steven <[hidden email]> wrote:
I don't know how to cool down after 24 hour work and fail.  And all the
office stop because of this.

I am not blaming anyone, because it is freeware.   But it really
problem.  Because I cannot host the server in China office, and I am not
always in Hong Kong.  So I must host the server in hosting company.  And
also I am not a programmer.

This restricted too much.  Anyway, I am trying to build in another
server from next hosting company.

Let see what happen next.

Steven

On 17/6/2010 7:23, ExsonQu wrote:
> HI, Steven,
>
>        Just coold down and figure thing out.
>        I've never try to upgrade the webERP from lower version to a lastest
> one. But I think we can solve the problem step by step. Since you've backed
> these sql data up, then I believe that we can upgrade the weberp system with
> some efforts.
>        Since there is several php scripts you have to run during the upgrade,
> you can record the error messages step by step, then we can pinpoint what's
> wrong with that step.
>         Best regards!
>         Exson
>

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/web-erp-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem after upgraded

TimSchofield5
This post was updated on .
In reply to this post by StevenTang
Hi Steven,

Are you really running mysql 4.1? This is quite old.

The sql error you gave in an earlier post (the worequirements one)
works fine on my database here but then I am running 5.1.41 of mysql.

If you want to send me a mysqldump of your database (to my private
email address I can try and help) but as someone else has said maybe a
support contract with someone would be a good idea.

Thanks
Tim

On 16 June 2010 16:11, Steven Tang <steven8tang@gmail.com> wrote:
> I don't know what to do now.
>
> I restore mysql back to 3.08, and re-upgraded one by one again.  and it is
> the same result.  The woEntry not work.
>
> So, I build a new database.  And found that it didn't work too.  ( it crash
> from the beginning after first input password as error :
>
> Database Error :
> You have an error in your SQL syntax. Check the manual that corresponds to
> your MySQL server version for the right syntax to use near 'WHERE
> currabrev='CHF'' at line 3
> Database SQL Failure : The SQL that failed was
> UPDATE currencies SET rate= WHERE currabrev='CHF'
>
> why it was work in utf8 with mysql 4.1?In the new sql have the line
> DEFAULT=Latin1 is not good for mysql 4.0.  I must remove them before ran.
>
> I'm not sure what to do.  But my utf8 server cannot print.  And now big5
> version even cannot work.  it go back to the situation like 4 years ago when
> I started to use webERP.  However, is I have 4 years data here now.  I think
> it is a little like sql syntax not compatiable in version.
>
> For the Cpdf problem of utf8.  I have an idea that it is the problem of VDS
> problem I faced before.  It is because of rootpath of includes.  because
> vhost root cannot be access.  But I forgot how to set it.  Need more time to
> check how I solve that in five years ago.
>
> How can I do?  Now is 11:00 at night.  Hope have someone help tomorrow
> morning.
>
> Thanks......
>
> Steven
>
>
>
> 2010/6/16 exson qu <hexinfans@gmail.com>
>>
>> Steven,
>>
>>               I'm not sure if you've backup the mysql data before your
>> upgrading. If you've kept the data, you can restore it and try it again.
>>               If you've not backed it up. You have a last solution to
>> backup your current mysql database data now. And then compare it with the
>> new version sql of weberp. It maybe time consuming.
>>
>>            Following is the suggestion about translation part, hope it's
>> helpful.
>>
>>            BTW, if you've installed webERP in windows, it's not necessary
>> to use utf8 version.
>>
>>
>>
>>
>>              Some suggestion about the translation as following:
>>
>>              1. Please read the basic knowledge about gettext in the
>> following sites:
>>
>> http://www.gnu.org/software/gettext/manual/gettext.html#Why  You can know
>> how does the gettext work? What is .po and what is .mo etc.
>>              2. After you get the principal of i18n and l10n, then you can
>> download a editor about PO. I use POedit and downloaded from following
>> sites:
>>               http://www.poedit.net/
>>             After install it, you can read the help documents to know how
>> to use it. Just click the help menu. There is no seperate documents such as
>> readme.
>>               3. You can go to the locale directory of weberp, then go to
>> the directory of .po and mo.  You can choose the .po file and open it with
>> POedit.
>>               4. If you want to extract the text need to be translated,
>> you can choose the Catalog menu and you can see that the first choice is
>> inactive (It means update the .po from source code, sorry I use Chinese
>> Edition so I don't know the exactly text.). In order to activate it, you can
>> click the setting choice in the same menu, then there is a window to add the
>> path, you can add the basic path of your weberp, and then add your weberp
>> directory. For example, you maybe have installed your weberp at
>> c:\AppServ\www (It's basic path), and you weberp maybe under it and is named
>> as weberp3.11.3, then you can put the weberp3.11.3 in the input boxes which
>> is below buttons aIe, X.  Then confirm it.
>>                5. Then the choice of update from source is activated in
>> Catalog menu, now you can click it. Then It will update your current .po
>> file. It will extract the texts to translate from the orignal file. those
>> texts are marked with _(' string') in those scripts.
>>               After you complete your translation, you can choose save as,
>> then you can save it as po and you'll get po and mo at the same time in the
>> directory which stores your files.
>>
>>          Hope it is helpful.
>>
>>          Exson Qu
>>
>>
>>
>>
>>
>> ------------------------------------------------------------------------------
>> ThinkGeek and WIRED's GeekDad team up for the Ultimate
>> GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
>> lucky parental unit.  See the prize list and enter to win:
>> http://p.sf.net/sfu/thinkgeek-promo
>> _______________________________________________
>> web-ERP-users mailing list
>> web-ERP-users@lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/web-erp-users
>>
>
>
> ------------------------------------------------------------------------------
> ThinkGeek and WIRED's GeekDad team up for the Ultimate
> GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
> lucky parental unit.  See the prize list and enter to win:
> http://p.sf.net/sfu/thinkgeek-promo
> _______________________________________________
> web-ERP-users mailing list
> web-ERP-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/web-erp-users
>
>



--
Course View Towers,
Plot 21 Yusuf Lule Road,
Kampala
T   +256 (0) 312 314 418
M +256 (0) 752 963 325
www.weberpafrica.com
@TimSchofield2
Blog: http://weberpafrica.blogspot.co.uk/

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
web-ERP-users mailing list
web-ERP-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/web-erp-users
For those wondering about the constant nastiness and abuse that Phil Daintree fires at me, the facts can be found here at http://weberpafrica.blogspot.co.uk/